Jump to content

  •  

CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.

Photo

Nexstar SLT Mount Missing Motor Drivers?

Beginner Celestron Equipment Mount Software
  • Please log in to reply
4 replies to this topic

#1 Clydeyy

Clydeyy

    Lift Off

  • -----
  • topic starter
  • Posts: 3
  • Joined: 30 Nov 2022

Posted 01 December 2022 - 08:40 AM

Hello everybody!

 

I just got into te telescope hobby and loved every second of it so far, but I'm having some issues with my Celestron SLT mount that I just can't get my head around...

 

I bought the Celestron 127SLT and it arrived last week. Everything seemed normal and worked like it should. 

 

Then for some reason after using the telescope for the third time, I get the "No response 16" message. Figured this had something to do with the batteries I was using, so I changed them, but the message kept coming back. Tried it with a powersupply (12V 2.5A), but still getting the same message. 

 

When looking online I found some methods to try and fix this, but till now nothing has worked. 

 

This is what I have tried so far:

 

- Trying to update the software of HC and MC (HC worked but MC states one of the versions of the motor is ?.?? and the other 5.18).

- Opened up the hand controller to see if I could see any loose contacts, but found nothing. 

- Reached out to Celestron and the seller, but haven't heard back from either. 

 

It looks like the handcontroller can't seem to connect to one of the motors for some reason. 

 

I'm hoping maybe you guys have some suggestions for things I could try. As you can imagine I'm really bummed out.

 

Thanks in advance!

 

Clyde 



#2 Jim Davis

Jim Davis

    Fly Me to the Moon

  • *****
  • Posts: 5,411
  • Joined: 05 Jul 2014
  • Loc: Lewisberry, PA

Posted 01 December 2022 - 08:59 AM

As you already know, Error 16 and 17 mean the hand controller cannot communicate with the motor controllers. Most of the time this is due to damage to the HC cord. Check the end that plugs into the mount to see if it is pulled off a bit.

 

The bad news here is your description sounds like the bad connection is internal. You are getting the MC version from one controller, but not the other. Either the internal wiring is damage, or the board is fried. If you take it apart, you may be able to find a lose connection.

 

Information on these issues can be found here: https://www.nexstars.../NoResponse.htm



#3 Nemo51

Nemo51

    Ranger 4

  • *****
  • Posts: 343
  • Joined: 25 Aug 2021

Posted 01 December 2022 - 09:04 AM

If Amazon, or a good seller, return it asap. 



#4 Clydeyy

Clydeyy

    Lift Off

  • -----
  • topic starter
  • Posts: 3
  • Joined: 30 Nov 2022

Posted 01 December 2022 - 10:20 AM

As you already know, Error 16 and 17 mean the hand controller cannot communicate with the motor controllers. Most of the time this is due to damage to the HC cord. Check the end that plugs into the mount to see if it is pulled off a bit.

 

The bad news here is your description sounds like the bad connection is internal. You are getting the MC version from one controller, but not the other. Either the internal wiring is damage, or the board is fried. If you take it apart, you may be able to find a lose connection.

 

Information on these issues can be found here: https://www.nexstars.../NoResponse.htm

Hi Jim, 

 

Thanks for the quick reply! 

 

I reseated all the connections in de mount and handcontroller, but it didn't seem to work. I can however move the mount up and down, something I couldn't before reseating. I've checked the board and couldn't see any indication it could be fried, accept maybe an electrical smell...

 

Think this could be a lost case...

 

Thanks for your help and time Jim, it's really appreciated!

 

edit: One thing I didn't mention earlier is that in some rare cased when I turn on the mount the motor turns by itself clockwise and doesn't stop. When this happens I don't have any control, so I think the problem should be in the HC connection with the mount and not the motor itself. 


Edited by Clydeyy, 01 December 2022 - 10:31 AM.


#5 Clydeyy

Clydeyy

    Lift Off

  • -----
  • topic starter
  • Posts: 3
  • Joined: 30 Nov 2022

Posted 01 December 2022 - 10:21 AM

If Amazon, or a good seller, return it asap. 

I don't think I have a choice at this point... undecided.gif




CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.


Recent Topics





Also tagged with one or more of these keywords: Beginner, Celestron, Equipment, Mount, Software



Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics