Jump to content


CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.


Issues with controlling SW Star Adventurer GTi through win PC

Astrophotography Mount
  • Please log in to reply
3 replies to this topic

#1 Frostak


    Lift Off

  • -----
  • topic starter
  • Posts: 10
  • Joined: 13 Apr 2020
  • Loc: SK

Posted 29 May 2023 - 11:03 AM



I've recently upgraded my setup purchasing a mini PC to control the rig remotely. However, I've run into a couple of issues that ruined my last 3 sessions.


The first issue is with slewing and plate solving when connected through usb. Using NINA, I'm able to do the three point polar alignment without issues. After that I go through framing assistant to slew to target. The telescope slews roughly to the correct position, plate solves (ASTAP), finds out it is off by bit and tries to reslew. However it gets stuck in slewing, thinking the telescope is slewing and waiting for it to finish, tho the telescope does nothing. After this point nothing really works and it almost seems as if the connection to the telescope was lost. However SynScan app still seems to be connected and manual slewing works. Note that I went to platesolving settings and enabled syncing and reslewing to target. Unfortunatelly, I currently don't have logs for this.


I tried connecting using wi-fi instead of usb. This resolved the issue above and NINA correctly slewed to target and corrected the position. However now PHD2 is unable to connect to the mount stating that the mount doesn't support PulseGuide (logs attached). PHD2 was also unable to automatically find the mount through wi-fi and I had to set the IP manually in ASCOM settings. Based on the logs it seems more like phd was unable to find the mount, rather then mount not supporting the PulseGuide (since through USB connection it has no issue with it). So I might be missing something here, maybe ASCOM supports only wired connection?


Anyway, I was wondering if anyone has run into these issues or would be able to give advice what to do. I'm at my wits end as to what to do.
One thing I noticed is that in the PC power settings, USB selective suspend was enabled, so maybe the PC itself shut off the wired connection to mount cousing the slewing issues. I tried disabling it, but didn't have the opportunity to try it out yet.


Thanks for any advice.


Relevant equipment info


Mount: SW Star Adventurer GTi

PC: Windows 11 Pro, SynScan app with ascom drivers, NINA, PHD2

Attached Files

#2 Adrian Gayer

Adrian Gayer

    Lift Off

  • -----
  • Posts: 1
  • Joined: 05 Mar 2023

Posted 22 August 2023 - 02:27 AM

I have a very similar setup and run in the same thing that you described. Did you manage to find a solution since then? If you did please give me some information so i can also make my setup work. Thanks! :)

#3 danny1976



  • -----
  • Posts: 1,436
  • Joined: 02 Nov 2021
  • Loc: Belgium

Posted 22 August 2023 - 06:25 AM

In APT the Star Adventurer GTI works perfect with the Heq5/6 Ascom driver. I tried the Synscan App Ascom driver from Skywatcher website but can't get a connection with the mount.
As I already use the eq6r I can just connect with the same Heq5/6 Ascom driver. Tried it out last night and works very well.
  • steviebee likes this

#4 Whalensdad


    Ranger 4

  • *****
  • Posts: 365
  • Joined: 30 May 2009
  • Loc: Southern CT

Posted 25 August 2023 - 07:49 PM

I haven't had this issue. I use Green Swamp Server instead of Synscan to control the mount.

CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.

Recent Topics

Also tagged with one or more of these keywords: Astrophotography, Mount

Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics