Jump to content

  •  

CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.

Photo

skyFi connection problem

  • Please log in to reply
11 replies to this topic

#1 No1umfan

No1umfan

    Vostok 1

  • -----
  • topic starter
  • Posts: 112
  • Joined: 07 Jun 2016

Posted 21 March 2024 - 02:13 PM

anybody using a skyfi module for wifi with a meade lx200 gps. I can't get this thing to connect reliably. usually have to reboot my phone and the skyfi multiple times and maybe 1 out of 20 times it will connect. I guess it could be the serial cable but I can connect with the same cable to my laptop no problem. want to use sky safari off my ipad to send commands to the scope.



#2 michael8554

michael8554

    Skylab

  • *****
  • Posts: 4,040
  • Joined: 19 Aug 2020
  • Loc: Wiltshire UK

Posted 22 March 2024 - 05:42 AM

You have the SkyFi connected to the RS232 socket with a serial cable ?

 

And you try to connect standing next to the mount with the phone ?

 

iOS or Android ?

 

Is it more reliable with an external 5V plugged in ?



#3 No1umfan

No1umfan

    Vostok 1

  • -----
  • topic starter
  • Posts: 112
  • Joined: 07 Jun 2016

Posted 22 March 2024 - 07:11 AM

Standing right next to the telescope. Using internal power on the Skyfi . Not plugged in. Using iOS on an iPhone. Yes plugged into the RS 232 port.

#4 DAVIDG

DAVIDG

    Hubble

  • *****
  • Posts: 12,584
  • Joined: 02 Dec 2004
  • Loc: Hockessin, De

Posted 22 March 2024 - 09:40 AM

 Is the problem  that programs like Sky Safari can't make a connection to the telescope or is that your phone or tablet can't make a connection to the SkyFi ? 

 If the problem is Sky Safari won't connect, turn on the  log file and look at what is being sent out and back and what the error message is.   There are two RS232 port on LX200GPS, the one closest to the hand controller port is polled more then the other one so if your not using it, try that one as well.  Also the mount needs to be fully booted up to  respond to serial commands. So if you have the GPS on and it searching for a signal the mount won't respond . You might have to have the scope fully aligned also for it respond to serial commands and not just in the alignment mode. 

    

 

                 - Dave 



#5 No1umfan

No1umfan

    Vostok 1

  • -----
  • topic starter
  • Posts: 112
  • Joined: 07 Jun 2016

Posted 22 March 2024 - 10:42 AM

 Is the problem  that programs like Sky Safari can't make a connection to the telescope or is that your phone or tablet can't make a connection to the SkyFi ? 

 If the problem is Sky Safari won't connect, turn on the  log file and look at what is being sent out and back and what the error message is.   There are two RS232 port on LX200GPS, the one closest to the hand controller port is polled more then the other one so if your not using it, try that one as well.  Also the mount needs to be fully booted up to  respond to serial commands. So if you have the GPS on and it searching for a signal the mount won't respond . You might have to have the scope fully aligned also for it respond to serial commands and not just in the alignment mode. 

    

 

                 - Dave 

I've tried both ports. typically use the one closest to the hand controller. I try to connect skyfi after the GPS fix is done and alignment is complete. But I dont turn the GPS off after the initial fix. My phone can see the skyfi and can connect to its WIFI.  Where do I get the error logs? Off the skyfi or from the autostar hand controller?



#6 DAVIDG

DAVIDG

    Hubble

  • *****
  • Posts: 12,584
  • Joined: 02 Dec 2004
  • Loc: Hockessin, De

Posted 22 March 2024 - 02:29 PM

 You get the log file  from Sky Safari and it is stored on your phone or tablet.  You need to turn the option on in Sky Safari were you setup the connection to your telescope. I'm still not clear when in the process your having the connection problem. Is it when your trying to connect your phone to the Sky Fi  or is it when your trying to control the  LX200GPS  using Sky Safari on your phone ?  

 

                - Dave 



#7 No1umfan

No1umfan

    Vostok 1

  • -----
  • topic starter
  • Posts: 112
  • Joined: 07 Jun 2016

Posted 22 March 2024 - 09:46 PM

Skyfi and SkySafari seem to be working together fine. It’s when I try to control the scope from Sky Safari that I get the connection error.

#8 DAVIDG

DAVIDG

    Hubble

  • *****
  • Posts: 12,584
  • Joined: 02 Dec 2004
  • Loc: Hockessin, De

Posted 23 March 2024 - 10:33 AM

 So if  I understand, you can connect to the SkyFi with no problem. In Sky Safari reports that you have made a connection to the scope and reports no errors then you loose the WIFI connection to the Sky FI. Is this correct or Sky Safari reporting it can make a connection to the telescope but the telescope is not responding ?  

   Are you connecting to the SkyFi in Sky Safari in station mode or access point mode ?  Did you buy the SkyFl new or used  since you can connect directly to the SkyFi can configure to  different modes.  You might try resetting it back to the default mode or setting it to  access mode and have Sky Safari directly connect to it via having it setup a local network. I believe the IP address that you enter into web browser is 192.168.2.1 and the password is 1234567  That will bring up a webpage were  you can change the configuration.  

  One thing comes to mind in  that I had similar problem with Sky Safari and my Skywatch mount  that used the Skywatcher  App to talk to the mount and Sky Safari was talking to the App. I had to tell my phone to allow both apps to have full power control. Since when the Skywatcher app was in the background it turned  the Wifi connection off to save power. 

 

                  - Dave 



#9 No1umfan

No1umfan

    Vostok 1

  • -----
  • topic starter
  • Posts: 112
  • Joined: 07 Jun 2016

Posted 24 March 2024 - 09:30 PM

 So if  I understand, you can connect to the SkyFi with no problem. In Sky Safari reports that you have made a connection to the scope and reports no errors then you loose the WIFI connection to the Sky FI. Is this correct or Sky Safari reporting it can make a connection to the telescope but the telescope is not responding ?  

   Are you connecting to the SkyFi in Sky Safari in station mode or access point mode ?  Did you buy the SkyFl new or used  since you can connect directly to the SkyFi can configure to  different modes.  You might try resetting it back to the default mode or setting it to  access mode and have Sky Safari directly connect to it via having it setup a local network. I believe the IP address that you enter into web browser is 192.168.2.1 and the password is 1234567  That will bring up a webpage were  you can change the configuration.  

  One thing comes to mind in  that I had similar problem with Sky Safari and my Skywatch mount  that used the Skywatcher  App to talk to the mount and Sky Safari was talking to the App. I had to tell my phone to allow both apps to have full power control. Since when the Skywatcher app was in the background it turned  the Wifi connection off to save power. 

 

                  - Dave 

So I found where you could turn on the log button in settings. It’s not on by default. Once I turned on the log tracking everything started working fine. Sky safari could control the telescope through the studio skyfi. I didn’t do anything else different.  So I think I’m on for now. You mentioned station mode and access point mode above however. What does that refer to. What’s the pros cons of each and how do you set that up. I couldn’t find anything in settings to change that setting 



#10 DAVIDG

DAVIDG

    Hubble

  • *****
  • Posts: 12,584
  • Joined: 02 Dec 2004
  • Loc: Hockessin, De

Posted 26 March 2024 - 08:52 AM

 I'm glad to hear that is working but I have no idea why turning on the Log file in SkySfari fixed the issue. Also having the Log file turned on means that every command sent to and from the telescope is being captured so the file is going to get large very quickly. 

   Access mode is when only two devices are connected to each other. So in this case your phone or tablet is connected only to the SkyFi and no other device. In station mode you can connect to network like your home network. The range can be longer and you can have access to other devices on the network. 

 

                  - Dave 


  • No1umfan likes this

#11 No1umfan

No1umfan

    Vostok 1

  • -----
  • topic starter
  • Posts: 112
  • Joined: 07 Jun 2016

Posted 26 March 2024 - 10:21 AM

 I'm glad to hear that is working but I have no idea why turning on the Log file in SkySfari fixed the issue. Also having the Log file turned on means that every command sent to and from the telescope is being captured so the file is going to get large very quickly. 

   Access mode is when only two devices are connected to each other. So in this case your phone or tablet is connected only to the SkyFi and no other device. In station mode you can connect to network like your home network. The range can be longer and you can have access to other devices on the network. 

 

                  - Dave 

thanks. Will keep an eye on that log file.  By the way can i do a rough alignment with the autostar then connect to sky safari and sync to an object and achieve precise GOTO capability. Or do I still need to be meticulous with my initial alignment with autostar.



#12 DAVIDG

DAVIDG

    Hubble

  • *****
  • Posts: 12,584
  • Joined: 02 Dec 2004
  • Loc: Hockessin, De

Posted 26 March 2024 - 01:43 PM

 You need to do an accurate alignment using the Autostar II and then take control of the scope with Sky Safari to point it.  The pointing model is created in the mount and not in Sky Safari  for this type of telescope control.  When I do this with my homemade Wifi or Bluetooth adapters, the GOTO using Sky Safari are usually dead on. Sky Safari  is sending the scope the RA and DEC of the object  you want to observe. The SYNC command in  Sky Safari maybe sending a command that is the same as holding down the Enter key on the Autostar II to sync on  an object once it is centered in the eyepiece but you need that initial alignment with the Autostar to have accurate GOTO's  You can check in the LOG file to see what  command if any is being sent to the mount when you issue a SYNC command in Sky Safari 

 

 The command  would be 

:CM# Synchronizes the telescope's position with the currently selected database object's coordinates.
Returns:
LX200's - a "#" terminated string with the name of the object that was synced.
Autostars & LX200GPS - At static string: " M31 EX GAL MAG 3.5 SZ178.0'#"

 

  Here is a link to the full command set. 

 

http://www.company7....0CommandSet.pdf

 

 

            - Dave 


  • Skywatchr and No1umfan like this


CNers have asked about a donation box for Cloudy Nights over the years, so here you go. Donation is not required by any means, so please enjoy your stay.


Recent Topics






Cloudy Nights LLC
Cloudy Nights Sponsor: Astronomics